Status
Get in touch
Back
Maintenance
Database upgrades
Completed
5 days and 5 hours ago
.
Affected services
Screen App
Manage
Legacy Services
Share
Completed
Maintenance completed
Posted
5 days and 5 hours ago
.
Started
Upgrades are complete
Posted
5 days and 5 hours ago
.